Bienvenido a Tecnohackers

Tecnohackers » Cultura y Ocio » Juegos PC y Consolas
 » 

Quake 4 para linux [Completo]



Autor Tema: Quake 4 para linux [Completo]  (Leído 657 veces)

Desconectado dangus92

  • Asiduo
  • *
  • Mensajes: 76
  • ::..Informática a full..::
Quake 4 para linux [Completo]
« en: Noviembre 09, 2009, 05:59:45 pm »
Quake IV

Quake 4 es un videojuego de acción en primera persona (FPS), el cuarto de la saga Quake, desarrollado por la popular empresa id Software y Raven Software.



Parece incrible que con estos gráficos haya salido para Linux, pero asi es.


Quake 4 utiliza con gran acierto la imaginería futurista de iD Software para crear impresionantes campos de batalla en el que tú y otros jugadores se enfrentaran en diferentes modos de juego como Capturar la Bandera, Combate a Muerte o Por Equipos. Lo mejor es que en Quake 4 no tienes complejas teclas ni tácticas, la única opción es la lucha más cruenta.


En Quake 4 interpretas a un Marine llamado Matthew Kane asigando al escuadrón Rhino, con el vivirás las aventuras durante la guerra en el planeta Strogg. Su motor basado en el juego Doom 3 e impresiona.


 [SIZE=18]Requisitos Minimos[/SIZE]

- Sistema GNU/Linux
- Pentium(r) 4 2.0 GHz or Athlon(tm) XP 2000+ processor
- 512MB RAM
- Kernel 2.4, 2.6 [recomendado]
- glibc >= 2.2.4

Aceleración 3D [no es requerida para servidores dedicados]:
   - SDL >= 1.2
   - ültimos drivers OpenGL, configurados correctamente
   - ATI(r) Radeon(r) 9700
   - ATI Radeon 9800
   - ATI Radeon X300 series
   - ATI Radeon X550 series
   - ATI Radeon X600 series
   - ATI Radeon X700 series
   - ATI Radeon X800 series
   - ATI Radeon X850 series
   - Nvidia(r) GeForce(TM) 3/Ti series
   - Nvidia GeForce 4/Ti series
   - Nvidia GeForce FX series
   - Nvidia GeForce 6 series
   - Nvidia GeForce 7 series

Audio [no es requerida para servidores dedicados]:
   - tarjeta de sonido con soporte OSS o Alsa, el sonido envolvente estéreo y cuentan con el apoyo tanto WTH APIss
   Alsa> = 1.0.6 es necesario para el sonido alsa Backend

Multiplayer:

   - Internet (TCP / IP) y LAN (TCP / IP) soportado para jugar.
   - Internet requiere conexión de banda ancha

------------------------------------------------------------------------------------------

   Instalación

Primero, tendremos que descargar el binario ejecutable que nos permita instalar el juego en GNU/Linux. Podemos descargarlo desde el servidor FTP de id Software. El enlace de descarga directo es el siguiente:

Citar
wget You are not allowed to view links. Register or Login (228 MB)
ó

Descargar: You are not allowed to view links. Register or Login

Para instalarlo simplemente tenemos que hacer doble clic sobre el archivo descargado, y elegir Ejecutar en un terminal en el diálogo que se nos abrirá. Si no aparece esa opción, es que no tiene permisos de ejecución. Para dárselos, desplegamos el menú contextual sobre el archivo (botón derecho del ratón), seleccionamos Propiedades -> Permisos, y marcamos la primera y segunda casilla de ejecución.

El instalador es el Loki installer, que permite instalar a golpe de ratón, es decir: siguiente, siguiente siguiente ...


Citar
Yo en mi caso lo instalé en otra dirección para más fácil a la hora de copiarlos.
Una vez instalado, debemos copiar a mano los archivos que necesita. Para ello, copiamos de la carpeta "Setup/Data/q4base" del CD del juego los siguiente archivos:

    * game000.pk4
    * pak001.pk4
    * pak002.pk4
    * pak003.pk4
    * pak004.pk4
    * pak005.pk4
    * pak006.pk4
    * pak007.pk4
    * pak008.pk4
    * pak009.pk4
    * pak010.pk4
    * pak011.pk4
    * pak012.pk4
    * zpak_english.pk4
    * zpak_spanish.pk4

Descargar Archivos: You are not allowed to view links. Register or Login

Citar
Pesan 210Mb cada uno.
Bueno,, los tuve que partir en partes. Ahí en el link tambien está el programilla para unir los archivos.
Cualquier duda,, preguntar.
Ahora ya podemos ejecutar Quake 4.

El archivo de configuración de Quake 4 es: ~/.quake4/q4base/Quake4Config.cfg. Ahi podeis trastear todo lo que querais. Podeis hacer que os muestre el número de frames por segundo (fps) ó utilizar una versión anterior de los shaders, para que funciona más rápido. Modificando este fichero, se puede hacer funcionar Quake 4 con una simple Voodoo 3 :)

Una ves que te bajaste todos los archivitos y los uniste con el progamilla tenes que copiarlos en la carpeta:
/usr/local/games/quake4/q4base

para eso vas a necesitar permiso de superusuario (root)

------------------------------------------------------------------------------------------


    Problemas frecuentes

Distorsión del sonido

GNU/Linux ha cambiado recientemente su sistema de sonido, antes usaba OSS y ahora usa ALSA, que es mucho mejor pero no funciona bien con algunas tarjetas, provocando distorsión en el sonido. Si sucede esto, tendremos que usar OSS, para ello instalamos el paquete oss y reiniciamos el juego con el siguiente comando:

Citar
$ quake4 +set s_driver oss
Compatibilidad con procesadores de 64 bits

Si usamos un procesador de 64 bits, tendremos que instalar el paquete ia32-libs de los repositorios oficiales de Ubuntu, para poder ejecutar programas de 32 bits.


------------------------------------------------------------------------------------------


   CD-Key que pide dentro del juego:

FPXXFDN7PX99HPJ9DKMK

------------------------------------------------------------------------------------------

Bueno Linuxeros,, eso es todo.
Espero les sirva de mucho a los que aman este juego como yo xD

Gracias a Skywalker,, me salvó la vida con este juego!!  :mrgreen:
(Actualizado y Archivos Necesarios Incluidos,, subidos por mi,, si alguien me puede conseguir la mayor cantidad de CD-KEY's,, sobradisimo :-D)

Fuente: Kwodahn_120
« Última modificación: Marzo 31, 2010, 04:51:25 pm por dark angel »

Tags:
Tags:

 


SMF 2.0.11 | SMF © 2015, Simple Machines
Paginas Afiliadas
Twitter - FaceBook - Daraxblog
Designed by Smf Personal